AnswerBun.com

rubyでスクレイピングをしたいが、mechanizeがrequireできない

スタック・オーバーフロー Asked by user25601 on December 14, 2020

スクレイピングをしようとして実行すると以下のように表示されます。
調べてもわからず困っています。どなたか解決方法をお願いいたします。

$ ruby scraping_image.rb

/Users/〇〇〇/.rbenv/versions/2.3.1/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- mechanize (LoadError)

from 
/Users/〇〇〇/.rbenv/versions/2.3.1/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from 
scraping_image.rb:1:in `<main>`

One Answer

gem list コマンドでインストール済みの gem 一覧を得て、mechanize があるか確認してください。macOS / Unix / Linux 環境では gem list | grep mechanize で見やすい出力が得られます。rbenv を使っていらっしゃるようなので、念の為確認してみてください。

Answered by nekketsuuu on December 14, 2020

Add your own answers!

Related Questions

JavaのデバックログにCQL文を出したい

1  Asked on November 20, 2021 by tokyo-walker

   

cuDNNの初期化が失敗する

0  Asked on November 17, 2021 by shinya-kurokawa

         

OSX用にビルドしたアプリが開けない。

1  Asked on November 15, 2021 by fujigiwa2

   

Ask a Question

Get help from others!

© 2022 AnswerBun.com. All rights reserved. Sites we Love: PCI Database, MenuIva, UKBizDB, Menu Kuliner, Sharing RPP