AnswerBun.com

Problem with gnome-software under Ubuntu 18.04.4 LTS (Bionic Beaver) because of Proxy Authentication Required

Ask Ubuntu Asked by FrançoisN on November 5, 2020

I have a problem with the application gnome-software under Ubuntu 18.04.4 LTS (Bionic Beaver) in my virtual machine of Oracle VM VirtualBox.
I am unable to access the applications in the gnome-software software library due to the proxy problem.

I have these 3 error messages:

  1. 08: 55: 54: 0026 Gs failed to call gs_plugin_refresh on shell-extensions: [* / * / * / source / shell-extensions / *] failed to download https://extensions.gnome.org//static/extensions .json: Proxy Authentication Required
  2. same problem for fwupd: Proxy Authentication Required
  3. same problem for odrs: Proxy Authentication Required

enter image description here

However, I have followed the explanations on the internet several other links.

I have defined my proxy:

  1. in my ".bashrc" file which contains 4 exports:
    export HTTPS_PROXY=’http://userName:[email protected]:myPortNumber’
    similar to : export HTTP_PROXY=’…’
    similar to export https_proxy=’…’
    similar to export http_proxy=’…’
  2. In the Preferences under the Network tab, I defined authentication for my proxies,

enter image description here

  1. and also in /etc/apt/apt.conf.d/proxy.conf with
    Acquire::http::Proxy "http://userName:[email protected]:myPortNumber";
    Acquire::https::Proxy "http://userName:[email protected]:myPortNumber";

My password contains a special character $, I replaced it with the equivalent of hexadecimal code which is "%24".

After running the commands below:

sudo apt update -y && sudo apt upgrade -y
sudo apt full-upgrade
sudo apt install meld
sudo apt install git

it works without problems!

My Firefox application works without problems!

I reinstalled Ubuntu 2 times but I still have these 3 error messages from the gnome-software application:

  1. killall gnome-software
    gnome-software
  2. sudo apt-get install -f gnome-software
  3. sudo apt install --reinstall gnome-software
  4. sudo apt-get remove gnome-software
    sudo apt-get install -f gnome-software

The online order of gnome-software indicates:

enter image description here

Could you help me to understand if this is a bug or how to fix it?

I can’t find the answers on the internet. I have tried all of the methods listed on the internet.

Add your own answers!

Related Questions

systemctl –state=failed

0  Asked on December 5, 2021 by tomasz-groch

 

Systemctl failure using –global setting

1  Asked on December 5, 2021 by mark-knittel

   

Ubuntu 20.04 – Failed to start GNOME Shell on X11

0  Asked on December 4, 2021 by facundo-flores

       

Google (maybe the browser?) not recognizing USB webcam

0  Asked on December 4, 2021 by tkbegemot

         

How to do a clean reinstall of ubuntu?

2  Asked on December 3, 2021 by mahiro

 

Cannot delete print job on Ubuntu 18.04

1  Asked on December 3, 2021 by manfred-steiner

 

Postfix is not logging anything to journal

1  Asked on December 3, 2021 by r4ptor

     

systemctl enable fprintd.service fails

1  Asked on December 3, 2021 by randy-broman

   

Recovering a lost user group

1  Asked on December 3, 2021

 

Ask a Question

Get help from others!

© 2022 AnswerBun.com. All rights reserved. Sites we Love: PCI Database, MenuIva, UKBizDB, Menu Kuliner, Sharing RPP