AnswerBun.com

Cannot login to my original account: io.elementary.greeter Unable to Log In Starting the session has failed (Can't find session 'xfce')

elementary OS Asked on January 6, 2022

Details
Session returned error code 1

I was attempting to install VNC Server via this walk-through, but this is where I went wrong (hindsight being 20/20):
sudo apt install xfce4 xfce4-goodies

I have created a new sudoer account, but I really want to get my original one working again. When I try to login to it, I see this:
unable_to_login

Here is the last bit of my /var/log/lightdm/lightdm.log file:

[+0.60s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.60s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+1.46s] DEBUG: Got signal 10 from process 808
[+1.46s] DEBUG: XServer 0: Got signal from X server :0
[+1.46s] DEBUG: XServer 0: Connecting to XServer :0
[+1.49s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+1.49s] DEBUG: Session pid=828: Started with service 'lightdm-greeter', username 'lightdm'
[+1.50s] DEBUG: Session pid=828: Authentication complete with return value 0: Success
[+1.50s] DEBUG: Seat seat0: Session authenticated, running command
[+1.50s] DEBUG: Session pid=828: Running command /usr/lib/lightdm/lightdm-greeter-session /usr/sbin/io.elementary.greeter
[+1.50s] DEBUG: Creating shared data directory /var/lib/lightdm-data/lightdm
[+1.50s] DEBUG: Session pid=828: Logging to /var/log/lightdm/seat0-greeter.log
[+1.59s] DEBUG: Activating VT 7
[+1.59s] DEBUG: Activating login1 session c1
[+1.59s] DEBUG: Seat seat0 changes active session to c1
[+1.59s] DEBUG: Session c1 is already active
[+1.90s] DEBUG: Greeter connected version=1.26.0 api=1 resettable=false
[+2.36s] DEBUG: Greeter start authentication for drewadmin
[+2.36s] DEBUG: Session pid=975: Started with service 'lightdm', username 'drewadmin'
[+2.37s] DEBUG: Session pid=975: Got 1 message(s) from PAM
[+2.37s] DEBUG: Prompt greeter with 1 message(s)
[+87.80s] DEBUG: Cancel authentication
[+87.80s] DEBUG: Session pid=975: Sending SIGTERM
[+87.80s] DEBUG: Greeter start authentication for andrew
[+87.80s] DEBUG: Session pid=1122: Started with service 'lightdm', username 'andrew'
[+87.80s] DEBUG: Session pid=975: Terminated with signal 15
[+87.80s] DEBUG: Session: Failed during authentication
[+87.80s] DEBUG: Seat seat0: Session stopped
[+87.81s] DEBUG: Session pid=1122: Got 1 message(s) from PAM
[+87.81s] DEBUG: Prompt greeter with 1 message(s)
[+91.65s] DEBUG: Continue authentication
[+91.67s] DEBUG: Session pid=1122: Authentication complete with return value 0: Success
[+91.67s] DEBUG: Authenticate result for user andrew: Success
[+91.67s] DEBUG: User andrew authorized
[+91.68s] DEBUG: Greeter requests session xfce
[+91.68s] DEBUG: Seat seat0: Failed to find session configuration xfce
[+91.68s] DEBUG: Seat seat0: Can't find session 'xfce'
[+97.60s] DEBUG: Greeter start authentication for andrew
[+97.60s] DEBUG: Session pid=1126: Started with service 'lightdm', username 'andrew'
[+97.61s] DEBUG: Session pid=1126: Got 1 message(s) from PAM
[+97.61s] DEBUG: Prompt greeter with 1 message(s)
[+106.43s] DEBUG: Seat seat0 changes active session to 

So, my question is how can I stop lightdm from trying to use xfce? I already tried apt purge it, but it was apparently not enough.

Final update: I have deleted Elementary OS from this machine and installed Ubuntu instead. As such I will never know what the fix was, or if this was fixable. Sorry

2 Answers

Developers who make Elementary OS rather do not use this forum, so complaining has totally no sense, because noone is able to solve the issue permanently. You can remove lightdm. If you will ask Google how to remove lightdm in Elementary OS Hera or Juno, you will find the answer. Besides the Elementary OS is Ubuntu/Debian based so solutions from these distros should work, but not always.

sudo apt purge lightdm
sudo apt install pantheon-xsession-settings
cd
sudo rm -rf .Xauthority
sudo nano /etc/gdm3/custom.conf

Change:

WaylandEnable=true 

to:

WaylandEnable=false

save changes and exit nano. Then type:

sudo reboot 

Answered by Sysadmin on January 6, 2022

I didn't install any shells. Just did an update 5.0 to 5.1 and after reboot have the same situation and search session 'pantheon'

[+0.95s] DEBUG: Seat seat0: Failed to find session configuration pantheon

[+0.95s] DEBUG: Seat seat0: Can't find session 'pantheon'

[+0.95s] DEBUG: Seat seat0: Creating greeter session

Answered by user19805 on January 6, 2022

Add your own answers!

Related Questions

Can i add multiple docks?

1  Asked on August 28, 2021

     

Validity Fingerprint 138a:0090 reader

3  Asked on August 28, 2021 by jason-murphy

 

Select muliple files does not function

1  Asked on August 28, 2021 by josepablo

     

How to enable manual login?

1  Asked on August 28, 2021 by cng

         

What happened to the Applications Menu?

3  Asked on August 28, 2021 by christopher-collins

         

Lenovo touchpad does not work

1  Asked on February 25, 2021 by amir-2mi

     

Install hangs with gray rectangle accross screen

1  Asked on February 22, 2021 by user2777128

 

root login from GUI

2  Asked on February 15, 2021 by jung

   

elementary OS hangs a lot

0  Asked on February 12, 2021 by awais-mirza

       

Thunderbird update not available

0  Asked on February 10, 2021 by bigera

     

Can i install elementary OS without grub bootloader?

0  Asked on February 6, 2021 by quark405

 

Ask a Question

Get help from others!

© 2022 AnswerBun.com. All rights reserved. Sites we Love: PCI Database, MenuIva, UKBizDB, Menu Kuliner, Sharing RPP