AnswerBun.com

Instance validation error: ' None ' is not a valid value for FrameType

I was making few UI changes to my SharePoint masterpage and I started getting following error, I also tried to restore previous versions of masterpage but that didnt work.
Can anyone help please.
In the error it says :

One of the properties of the Web Part has an incorrect format. Microsoft SharePoint Foundation cannot deserialize the Web Part.  Check the format of the properties and try again.]

but how I find which webpart has issue ?
My environment is SharePoint 2016.

Thanks in advance.

Server Error in '/' Application.

Instance validation error: '
                                            None
                                        ' is not a valid value for FrameType. 
  Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

 Exception Details: System.InvalidOperationException: Instance validation error: '
                                            None
                                        ' is not a valid value for FrameType.

Source Error: 


 An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.  

Stack Trace: 



[InvalidOperationException: Instance validation error: '
                                            None
                                        ' is not a valid value for FrameType.]
   Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderContentEditorWebPart.Read7_FrameType(String s) +223
   Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderContentEditorWebPart.Read12_ContentEditorWebPart(Boolean isNullable, Boolean checkType) +710
   Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderContentEditorWebPart.Read13_WebPart() +119

[InvalidOperationException: There is an error in XML document (9, 53).]
   System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, String encodingStyle, XmlDeserializationEvents events) +819
   Microsoft.SharePoint.WebPartPages.WebPart.ParseXml(XmlReader reader, Type type, String[] links, SPWeb spWeb) +210

[WebPartPageUserException: One of the properties of the Web Part has an incorrect format. Microsoft SharePoint Foundation cannot deserialize the Web Part.  Check the format of the properties and try again.]
   Microsoft.SharePoint.WebPartPages.WebPart.ParseXml(XmlReader reader, Type type, String[] links, SPWeb spWeb) +800
   Microsoft.SharePoint.WebPartPages.WebPart.AddParsedSubObject(Object obj) +1268
   System.Web.UI.ControlBuilder.BuildChildren(Object parentObj) +1067
   System.Web.UI.ControlBuilder.InitObject(Object obj) +479
   System.Web.UI.ControlBuilder.BuildObjectInternal() +285
   System.Web.UI.ControlBuilder.BuildChildren(Object parentObj) +888
   System.Web.UI.ControlBuilder.InitObject(Object obj) +479
   System.Web.UI.ControlBuilder.BuildObjectInternal() +285
   System.Web.UI.ControlBuilder.BuildChildren(Object parentObj) +888
   System.Web.UI.ControlBuilder.InitObject(Object obj) +479
   System.Web.UI.ControlBuilder.BuildObjectInternal() +285
   System.Web.UI.ControlBuilder.BuildChildren(Object parentObj) +888
   System.Web.UI.ControlBuilder.InitObject(Object obj) +479
   System.Web.UI.FileLevelPageControlBuilder.InitObject(Object obj) +42
   System.Web.Compilation.BuildResultNoCompileTemplateControl.FrameworkInitialize(TemplateControl templateControl) +168
   System.Web.UI.TemplateControl.FrameworkInitialize() +106
   System.Web.UI.MasterPage.CreateMaster(TemplateControl owner, HttpContext context, VirtualPath masterPageFile, IDictionary contentTemplateCollection) +1247
   System.Web.UI.Page.get_Master() +65
   System.Web.UI.Page.ApplyMasterPage() +17
   System.Web.UI.Page.PerformPreInit() +53
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1132

SharePoint Asked by AH Jamali on January 6, 2022

1 Answers

One Answer

I have figure out the issue, actually we have one content editor webpart placed on MasterPage in our staging environment. once we migrated the sitecollection we start getting this error. What fixed this issue: In order to fix it, we deleted that content editor webpart from Masterpage and created it again on production environment through Snippet Gallery.

Answered by AH Jamali on January 6, 2022

Add your own answers!

Related Questions

Library Search Permissions

1  Asked on December 26, 2020 by joe-fedorowicz

 

Exceeds Threshold

4  Asked on December 25, 2020

     

SPListItemCollection to Dictionary

1  Asked on December 24, 2020 by k-jones

     

Use SharePoint as front end for access

2  Asked on December 22, 2020 by dominica

   

Save Modal Dialog Field Value to Refresh Page DIV

1  Asked on December 22, 2020 by aurumpotabile

   

_x0020_ Not Working in AJAX

1  Asked on December 19, 2020 by bigchungus

       

Edit Hidden Item in List

1  Asked on December 18, 2020 by decave

       

Ask a Question

Get help from others!

© 2022 AnswerBun.com. All rights reserved.